Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    WebV: Subject Browse Searches labeling visited links incorrectly

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.2.1

    Description:
    Bug Report for Issue 16384-6817
    Module(s): WebVoyage
    Server platform(s) affected: All
    PC OS (if applicable): N/A
    Browser & version (if applicable): All Supported Browsers

    Release(s) replicated in: 7.1.0, 7.0.4, 7.0.1
    Last version without bug (if applicable): 6.5.4

    Expected results:
    If a user clicks on a link in a subject browse list, then go back to the list and navigates the next or previous page, the only link that will show as visited is the actual subject link the user selected.

    Actual results:
    If a user clicks on a link in a subject browse list, then go back to the list and navigates the next or previous page, all links that correspond to the position in the list of the actual visited link will show as though they were visited as well.

    Workflow implications: Users will not be able to keep track of which subjects they've already viewed if subsequent pages act the same way as the current one does.

    Replication steps:
    1.Run a subject browse for “history”
    2.Click on the first result in the list
    3.Go back one page by clicking on the “Subject” tab
    4.Notice that the link in step 2 now shows as visited (correctly)
    5.Now click on previous or next, and notice that the first item in each list shows as visited, even though these headings actually never were visited.

    Resolution:
    Fixed in Voyager 8.2.1


    • Article last edited: 3/7/2015
    //doorbell.io feedback widged