Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    WebV: Redirect links appear even when a field is not defined

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.1.1

    Description:
    Bug Report Form for Issue 16384-11985
    Module(s): WebVoy?ge
    Server platform(s) affected: Tested on Solaris
    PC OS (if applicable): N/A
    Browser & version (if applicable): All Browsers

    Release(s) replicated in: 7.2.2, 7.2.1, 7.0.4
    Last version without bug (if applicable): 6.5.4

    Expected results: If a redirect link is set up in the OPAC, then that link will be displayed if that subfield exists in Cat.

    Actual results: If a redirect link is set up on a subfield that is not defined in a certain bib record, a link will still be displayed, and it will result in an ISE.

    Workflow implications: Invalid links are displayed in the OPAC

    Replication steps:
    1. In Cataloging, create a new MFHD and attach it to any record.
    2. In said MFHD, create an 852 field with a subfield B and a subfield Z. The value of both of these fields does not matter
    3. In displayHoldings.xml, comment out the holdingTag labeled “Notes”, and modify the “Call Number” tag to the following:
    <holdingsTags label="Call Number:" notFound="No call number available">
    <displayTag field="852" indicator1="X" indicator2="X" subfield="khijz" redirect="callnumber" redirectOn="hi"/>
    </holdingsTags>
    4. Load this record in WebVoy?ge, you'll see the call number redirect link is enabled, but it should not be, since this record has no subfield H or I

    Resolution:
    Fixed in WebVoyage for 8.1.1.


    • Article last edited: 3/7/2015
    //doorbell.io feedback widged