Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    WebV: Double dashes in "notFound" message leads to ISE when commented out

    • Article Type: General
    • Product: Voyager
    • Product Version: 8.1.1

    Description:
    Bug Report Form for Issue 16384-2564
    Module: WebVoyage
    Release(s) replicated in: 7.0.1
    Server Platform(s) affected: All
    Browser type & version (if WebVoyage): IE7, FF2
    Loss of functionality from (previous version, if applicable): N/A

    Expected Results: Commenting out sections of the displaycfg.xml/emailcfg.xml files would not lead to internal server errors.

    Actual Results: Our default “notFound” message for the Holdings Information display has a double dash, which the XSL processor does not allow in comments. Commenting the section out (which is the preferred way of disabling certain elements from displaying) leads to an ISE when trying to view a record page.

    Workflow Implications: It’s easy to misconfigure and generate an ISE.

    Replication steps:
    1) Edit displaycfg.xml to comment out the “Holdings Information” section, as follows:
    <!--
    <displayTags label="Holdings Information" notFound="No holdings available -- check at the Circulation Desk.">
    <displayTag field="9000"/>
    </displayTags>
    -->
    2) Navigate to a record page in WebVoyage. You will get the error_500.html page.

    Other information: The workaround is to remove the double dashes from the “notFound” message as follows:
    notFound="No holdings available - check at the Circulation Desk."

    Resolution:
    Fixed in WebVoyage for 8.1.1.


    • Article last edited: 3/10/2015
    //doorbell.io feedback widged