Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Perl is using an old version of openssl

    • Product: All products using Perl
    • Relevant for Installation Type: Dedicated-Direct, Direct, Local, Total Care

     

    Symptoms

    When checking the openssl version used by Perl (using ldd or another method), it appears that Perl is using an old version of openssl even if 3rd-party products were recently updated and a newer version of openssl is installed on the server.

     

    Workaround

    This is in fact not an issue. In order to use a newer version of openssl, Perl needs to be recompiled, which is a complicated process. Since Perl is dealing with internal traffic or acting as an ssl client only, the version of openssl it uses does not affect security, and therefore updating it is left for a future release.

     

     


    • Article last edited: 20-March-2016
    //doorbell.io feedback widged