Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Errors indicating missing program - expand_doc_856

    • Article Type: General
    • Product: Aleph
    • Product Version: 17.01

    Description:
    I'm getting the error:

    missing program <expand_doc_856

    in a variety of logs. What is causing this?

    Resolution:
    The expand_doc_856 program was removed beginning with ALEPH V.17 from the Release Notes;
    **************************************************************************
    Release Notes -> Indexing -> Expand Routines -> expand_doc_856:.

    The expand_doc_856 has been removed. This expand was used in order to create URL tags from fields with URI content (defined in tab_buf_z403) in order to be processed by edit_doc and displayed in the Web OPAC. The expand was mostly used in the holdings library, in order to expand 856 fields from the bibliographic library. The documentation stated that in order to expand 856 fields from bibliographic record into the holdings records the following lines needed to be defined in the tab_expand table of the holdings library:.
    WEB-FULL expand_doc_hol_bib.
    WEB-FULL expand_doc_856.

    URL tags are now automatically created by the system. Regarding the fields with URI content expanded from the bibliographic library into the holdings library, it is now necessary to include the following line:.
    BUF-Z403 expand_doc_hol_bib
    **************************************************************************
    You should remove every line that includes a reference to expand_doc_856 in the tab_expand table in all your libraries - xxx01, xxx50, xxx60, etc. This will eliminate the error messages being generated.


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged