Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Error in aleph_shutdown: "Warning (tab_library_group): Invalid library in tab_library_group"

    • Article Type: General
    • Product: Aleph
    • Product Version: 20
    • Relevant for Installation Type: Dedicated-Direct; Direct; Local;

    Description:

    After upgrading Aleph with Upgrade Express, when running aleph_shutdown, the following messages appear in the aleph_shutdown log:


    stopping batch queue
    Load: /exlibris/aleph/u20_1/alephe/tab/tab_library_group
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX20
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX21
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX01
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX10
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX20
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX30
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX50
    Warning (tab_library_group) : Invalid library in tab_library_group - XXX60

    (etc.)
    Is this indicative of a problem? What can be done to correct the warnings?


    Cause:

    When shutting down the queues and daemons, aleph_shutdown reads ./alephe/tab/tab_library_group, as that file contains a list of libraries which share the same lib_batch and UE processes.

    These messages occur when tab_library_group contains a library which is not in $aleph_libs. It may contain libraries that are now obsolete (USM20, for instance, is the ILL library used prior to Aleph 20).

    These messages are just warnings and have no real effect.

    Resolution:

    To correct, perform the following commands on the server after signing in as the "aleph" user:

    1. echo $aleph_libs
    To display a list of all libraries.

    2. aet
    To move to the ./alephe/tab directory.

    3. vi tab_library_group
    To open the tab_library_group table for editing.

    4. Remove any libraries that appear in the warning messages from aleph_shutdown. If needed, add in any libraries that are in $aleph_libs that do not appear in this list.

    5. :wq
    To save changes.

    No further actions are needed. The next time aleph_shutdown is performed, these warnings will not appear.

    Subject: Migration


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged