Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Course Reserves Upgrade Express doc error; corrupted triggers

    • Article Type: General
    • Product: Aleph
    • Product Version: 19.01

    Description:
    Section 8.3 of the Upgrade Express 18.01 to 19.01 User Guide has the following steps:

    ...
    5. Run util/a/17/6/ to activate z127 trigger.
    6. Run union_01, union_02.
    7. Run the following from the command line in order to create the Z127 records:
    csh –f $aleph_proc/create_z127.

    I followed these steps and the result is corrupted triggers. This is util a/17/6/4 ("Show trigger status") after doing these steps:

    aleph_admin@ALEPH19> aleph_admin@ALEPH19> aleph_admin@ALEPH19> 2 3 4
    TRIGGER_NAME TABLE_NAME STATUS
    ------------------------------ ------------------------------ --------
    BIN$Yn47jdhWvjTgQAEKDutM1A==$0 BIN$Yn47jdhZvjTgQAEKDutM1A==$0 ENABLED
    BIN$Yn47jdhXvjTgQAEKDutM1A==$0 BIN$Yn47jdhZvjTgQAEKDutM1A==$0 ENABLED
    BIN$Yn47jdhYvjTgQAEKDutM1A==$0 BIN$Yn47jdhZvjTgQAEKDutM1A==$0 ENABLED


    I then did util a/17/6/1 to create the triggers and these (correct) values were created:

    aleph_admin@ALEPH19> aleph_admin@ALEPH19> aleph_admin@ALEPH19> 2 3 4
    TRIGGER_NAME TABLE_NAME STATUS
    ------------------------------ ------------------------------ --------
    Z127_TRIGGER Z120 ENABLED
    Z127_TRIGGER_1 Z120 ENABLED
    Z127_TRIGGER_2 Z120 ENABLED

    but the incorrect BIN$... triggers remain.

    Resolution:
    Section 8.3 of the Upgrade Express 18.01 to 19.01 User Guide needs to be changed to the following:

    ...
    5. Run union_01, union_02.
    6. Run the following from the command line in order to create the Z127 records:
    csh –f $aleph_proc/create_z127
    7. Run util/a/17/6/1 to create the z120/z127 triggers.


    This issue is still open and was escalated to Development for further investigation <2009-02-15 01:00:03>.


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged