Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Check Upgrade Environment --UE error: The IO::ALL module is missing ...

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Description:
    Check Upgrade Environment --UE error: The IO::ALL module is missing in the perl packag

    install_driver(Oracle) failed: Can't load '/waleph/aleph/a18_1/product/perl-5.8.7/lib/site_perl/5.8.7/sun4-solaris/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: ld.so.1: perl: fatal: /app/oracle/product/102/lib/libclntsh.so.10.1: wrong ELF class: ELFCLASS64 at /waleph/aleph/a18_1/product/perl-5.8.7/lib/5.8.7/sun4-solaris/DynaLoader.pm line 230.
    at (eval 1) line 3
    Compilation failed in require at (eval 1) line 3.
    Perhaps a required shared library or dll isn't installed where expected
    at ./source/proc/listner.pl line 12

    The IO::All module is not installed - you cannot run the kit

    (After solving KB 8192-3865 for the wrong ELF class, we are still getting this error for the IO::ALL.)

    Resolution:
    This was solved by doing this:

    >cd /waleph/aleph/a18_1/product_source/install
    >csh -f perl_add.csh

    The perl_add.csh script added IO::All module.

    In a similar AIX (version 20) instance the preceding did not work. See KB 16384-26849 for the solution to that case.

    Additional Information

    faq


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged