Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Certain doc records don't display for a particular course in Web Staff

    • Article Type: General
    • Product: Aleph
    • Product Version: 16.02

    Description:
    We are unable to add a specfic document to a course. The course is GEOG100-LT. The document is The Reformation.

    I select the course (it has plenty of documents added already), click on docs, catalog, enter the title: Reformation, click on send button. The tite does not get added to the list.

    The title does show up in the OPAC and can be viewed in the abc30 library catalog client.

    There are other documents that have the same problem for this course. But some docs get added just fine. What is the problem?

    Resolution:
    In order for a document to be included in the Web Staff Course Reserve Docs list for a particular course, it needs to have a Z11 "CNO" record connecting it to the course and a Z13 short doc record. This abc30 doc 000004150 does have the proper z11 and z13.

    The other is, as described in KB 8192-2103, the xxx30 base should not have any qualifiers. Yours is correct in that respect....

    The problem is that there are nine z11 records whose z11_text is "$$aGEOG100LT" rather than "GEOG100-LT".

    (The program is going through the z11_rec_key's looking for courses with the same Z11-FILING-TEXT *and* whose Z11-TEXT is the same as the Z11-TEXT of the preceding Z11. When it hits a record with different Z11-TEXT, it stops. Thus, even though the "Reformation" Z11 had the hyphen, the program was never getting to it because of the preceding records without the hyphen.)

    The root problem is the doc record CNO fields, from which the Z11-TEXT is derived, which have the GEOG100LT *without* the hyphen.

    What you need to do is to go into the following abc30 doc records and, for each that has a CNO field with of GEOG100LT, change it to GEOG100-LT....

    The moral of the story: If you are going to include the hyphen in the tab_filing as a "to_blank" or "compress" character for the tab_filing routine used for the CNO index, then you *must* be consistent in your use of hyphens in the CNO field in the xxx30 doc record.

    Additional Information

    faq


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged