Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Can't Update ALEPH Profile: "Library for ALEPH profile cannot be changed"

    • Article Type: General
    • Product: Aleph
    • Product Version: 20

    Description

    When I try to update the ALEPH profile in the GUI, I get this message: Library for "ALEPH" profile cannot be changed.

    xxx50 is the $usr_library.

    The z61 record via UTIL-F-4 looks like this:
    02 z61_rec_key \n
    03 id .........................ALEPH
    ...
    ...
    02 z61_base .....................ABC01PUB
    02 z61_con_lng ..................ENG
    02 z61_user_library ..............xxx50

    Resolution


    Every profile, except for ALEPH profile, can be defined to belong to a specific library.

    The reason that ALEPH profile can’t belong to a specific library is that it is a special profile that every library is using.

    Therefore when updating the ALEPH profile the z61_user_library field has to be empty.

    If the message "Library for "ALEPH" profile cannot be changed" is still there, the update will have to be done by SQL (z61).

     

    This means that if you want to change e.g. the standard language in z61_con_lng you have to do it using SQL.
     


    • Article last edited: 23-DEC-2016
    //doorbell.io feedback widged