Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    CREATE TABLE errors in Upgrade Express logs; "insufficient privileges"

    • Article Type: General
    • Product: Aleph
    • Product Version: 19.01

    Description:
    I have run Upgrade Express on our test server and have many CREATE TABLE errors in my logs (steps 1001, 1003, 1004, 1005, 1007, 1009, 1012).

    I had my DBA grant CREATE_TABLE privileges to user aleph and to aleph_admin.

    I have also get the following error doing "s+ abc50":

    user ABC50 lacks CREATE SESSION privilege; logon denied.

    I found some Knowlege Base entries that address this error that tell us to setup the passwords in Util Y/8 (my DBA tells me that currently the dba_users table has not passwords setup:

    SQL> select username,password from dba_users where username='ABC50';

    USERNAME PASSWORD
    ------------------------------ ------------------------------
    ABC50

    When I try to run Util Y/8 to set the passwords for the ABC libraries I get the following error:

    Enter ALEPH_DBA user/passwd, or press [Enter] to exit :aleph_dba/aleph_dba_pw_here
    Change passwd in Oracle

    SQL*Plus: Release 11.1.0.7.0 - Production on Tue May 11 11:43:21 2010

    Copyright (c) 1982, 2008, Oracle. All rights reserved.

    SQL> Connected.
    SQL> SQL> alter user ABC01 identified by new_pw
    *
    ERROR at line 1:
    ORA-00922: missing or invalid option

    How do I clean up all of these errors so I can run my failed Upgrade Express Oracle steps?

    [Later:]
    I was able to run util y/8 with no errors reported to set the ABCnn passwords. But Aleph still has no permissions to do anything (cannot create session, cannot create table, cannot update database, etc).

    [Later:]
    Our DBA granted all of the permissions for the ABCnn libraries that were in the create_ora_user script. I am now able to s+ abc01, etc.

    [Later:]
    I can now run s+ and do updates from s+ as any ABCnn user but still cannot do updates from Aleph. I just tried to do some renewals and get the following error in the logs:

    Oracle error: io_z65_update
    ORA-01031: insufficient privileges

    Resolution:
    The site needed to consult the "How to Upgrade Oracle Software and Database from Oracle Version 10.2.0.4 to 11.1" document. That doc includes a script to re-create the roles without passwords. As an oracle11 user, enter the following commands:

    cd /exlibris/ftp_from_exlibris/scripts/11
    csh -f fix_roles_def.csh


    [From site:] We should have all the requirements installed now per the post upgrade activities:

    COMP_NAME VERSION STATUS
    -------------------------------------------------- ------------ ----------
    Oracle XML Database 11.1.0.7.0 VALID
    Oracle Expression Filter 11.1.0.7.0 VALID
    Oracle Enterprise Manager 11.1.0.7.0 VALID
    Oracle Text 11.1.0.7.0 VALID
    Oracle Workspace Manager 11.1.0.7.0 VALID
    Oracle Database Catalog Views 11.1.0.7.0 VALID
    Oracle Database Packages and Types 11.1.0.7.0 VALID
    JServer JAVA Virtual Machine 11.1.0.7.0 VALID
    Oracle XDK 11.1.0.7.0 VALID
    Oracle Database Java Packages 11.1.0.7.0 VALID


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged