Skip to main content
ExLibris
  • Subscribe by RSS
  • ExLibris Dev

    Browse doesn't work for very small logical base

    • Article Type: General
    • Product: Aleph
    • Product Version: 18.01

    Description:
    I recently set up a logical base in tab_base.eng on our test server. The base code is nd_rome. There are currently 332 records in the base, but we expect this to grow to a few thousand as items are cataloged.

    The problem is that although keyword searching works fine, browse does not work at all, and eventually returns a blank screen.

    Resolution:
    I find that the following Browse *does* work:

    http://alephtest.library.nd.edu:8991/F/G5PDR3VY66BDDAVXBRDNHQCLQMENSETY5J3P2VQASN38IPTGD4-04306?func=scan&scan_code=TTI&scan_start=roman&local_base=nd_rome

    But, as you note, other Browses do not....

    Since these 332 records are about 1/8000-th of your total database and since the tab_base.eng entry for nd_rome has "N" in column 8, the system, in trying to produce a Browse display, will need to look at, on average, 8,000 headings (and their associated z02 records) before finding any which are in the base. I believe the result is that it is timing out in this process.

    If you specify "Y" in the tab_base.eng column 8 for nd_rome and then run p_manage_32, the job will find that the only base with "Y" is nd_rome and will run for this base only.

    Once the z0102 is in place (and you restart the www_server), the Browse will use the z0102 and should be able to produce the display without timing out.


    • Article last edited: 10/8/2013
    //doorbell.io feedback widged